Bug #410

Person

Add pmid to gene error

Added by Emmanuel Quevillon over 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:02/08/2011
Priority:HighDue date:
Assignee:PersonEmmanuel Quevillon% Done:

100%

Category:-Estimated time:0.25 hour
Target version:-Spent time:2.00 hours

Description

When we want to add a pmid to a gene (curate/add)

When the publication is not in the database yet:

Controller::Curate::Add->_create_confirmation_with_pmid "Cannot call set without at least 2 arguments at /home/tuco/src/perl/projects/Catalyst/BiblioList/dev/bibliolist/trunk/script/../lib/BiblioList/Parser/NCBIXml.pm line 166

When the publication is already in the database:

On the result page, the link to gene linked to pub 'host/search/?query=asg&stype=gene&id=539&partial=0' is erroneous and we then get an ERROR:[search/index] Wrong search type passed as argument ('gene')

History

#1 Person Updated by Emmanuel Quevillon over 9 years ago

  • Estimated time set to 2.00
  • % Done changed from 0 to 100
  • Status changed from New to Resolved

#2 Person Updated by Emmanuel Quevillon about 9 years ago

  • Estimated time changed from 2.00 to 0.25

Solved. Changed 'traits' from Hash to Array (error message thrown).
Due to this, also added the authors fetching from the database as well as the corresponding template. (r291)

#3 Person Updated by Emmanuel Quevillon about 9 years ago

  • Status changed from Resolved to Closed

Solved. Changed 'traits' from Hash to Array (error message thrown).
Due to this, also added the authors fetching from the database as well as the corresponding template. (r291)

Also available in: Atom PDF