Bug #585

Person

portal.html not XHTML compliant

Added by Olivier Sallou over 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:06/22/2011
Priority:NormalDue date:
Assignee:PersonHervé Ménager% Done:

100%

Category:-
Target version:1.0.1

Description

Customization of portal.html for a custom display is an issue with Mobyle updates.

File portal.html needs to be analysed etc... then custo display needs to be put back in file.

We are looking at a script to automate this update with a portal.html analysis.

The issue is this file is not XHTML compliant and cannot be parsed correctly by an XML analyser.

Some end tags are not present (td), <input> tags are not closed....

An XHTML compliance would allow easier custom for the other portals

An other possibility would be to add some tags in title/header/footer where tags would be replaced by static content defined in an other file.

History

#1 Person Updated by Hervé Ménager over 9 years ago

  • Target version set to 1.0.1
  • Assignee set to Olivier Sallou
  • Status changed from New to Feedback

I would rather choose the "replacement tags" in title/header/footer. Can you give me something like a drawing that describes what "areas" of the portal should be customizable/replaceable by the tags?

#2 Person Updated by Hervé Ménager about 9 years ago

  • Assignee changed from Olivier Sallou to Hervé Ménager

#3 Person Updated by Hervé Ménager about 9 years ago

  • Status changed from Feedback to Assigned

#4 Person Updated by Hervé Ménager about 9 years ago

ok, IMHO portal customization is not a bug, it's a feature. I cannot change this with the current version of redmine, so I'll keep it this way, but for the record...

#5 Person Updated by Hervé Ménager about 9 years ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved

fixed by r3823.

#6 Person Updated by Hervé Ménager about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF