Download

Before installing Mobyle, you should first have a look to the information given in the Administrator Guide.

Mobyle core system:

Stable (official) releases

Mobyle is distributed under GNU General Public License, version 2 licence.
Current branch is 1.5 which came out in february 2013, the last release is the 1.5.3 published on march 12th, 2014 and here are listed Changes between versions.

System requirements:

- apache http server
- python (>= 2.5 and <3.0)
- The following Python libraries:

- Optional:

  • squizz (>=0.99b) is helpful to convert Sequence/Alignment data
  • dnspython (>=1.5) to check user emails domain validity
  • golden is helpful to directly load biological sequences from databanks into the web portal
  • a batch system, such as
    > SGE
    > Torque ( enable drmaa during compilation phase )
    > LSF ( + lsf_drmaa )
    > drmaa-python is required for Torque and LSF DRM and if you intend to run SGE via DRMAA
  • the xml programs definitions ( >= 5.1.1 ) see below Mobyle xml program descriptions section.
  • biopython (>=1.61) required for conversion of alignement in phylip-relaxed format (it's not required to install reportlab or numpy).

Development version

You can download the development version from the public SVN Mobyle repository. With a command-line subversion client, type this line:

$ svn co https://projets.pasteur.fr/svn/mobyle/trunk

Then you can create the install package by going to the checked out folder (e.g., trunk), and using the distutils-based script:

$ cd trunk
$ python setup.py sdist

If everything works correctly, a new archive (Mobyle-XX.tar.gz) will be created in the dist subfolder.

Use of the development version is highly unrecommended for production servers. The code evolves (or can evolve) quickly, as do the configuration and requirements, and documentation may not be up-to-date.

System requirements:

- apache http server
- python (>= 2.5 and <3.0)
- The following Python libraries:

- Optional:

  • squizz (>=0.99b) is helpful to convert Sequence/Alignment data
  • dnspython (>=1.5) to check user emails domain validity
  • golden is helpful to directly load biological sequences from databanks into the web portal
  • a batch system, such as
    > SGE
    > Torque ( enable drmaa during compilation phase )
    > LSF ( + lsf_drmaa)
    > drmaa-python is required for Torque and LSF DRM and if you intend to run SGE via DRMAA
  • the xml programs definitions ( >= 5.1.1 ) see below Mobyle xml program descriptions section.
  • biopython (>=1.61) required for conversion of alignement in phylip-relaxed format (it's not need to install reportlab or numpy).

Mobyle xml program descriptions:

Current version is 5.1.2 which came out in July 2013. Beware, Mobyle >=1.5.0 needs program xml descriptions in version 5.0 or above.
The programs 4.0 version is compatible with versions 1.0.x

These descriptions are distributed under GNU Lesser General Public License, version 2.1 .

Mobyle xml viewers descriptions:

Current version is 1.0.1 which came out in May 2012.

System requirements:

You need to downloads the applets corresponding to each viewer you want to integrate in Mobyle.
For more details see service description guide (source:/tags/release_1_0_1/Doc/service_description_guide.pdf).

These descriptions are distributed under GNU Lesser General Public License, version 2.1 .

Mobyle xml workflows descriptions:

Current version is 1.1.2 which came out in march 2014.

These descriptions are distributed under GNU Lesser General Public License, version 2.1 .

Mobyle xml tutorials descriptions:

Current version is 1.5.0 which came out in february 2013.

These descriptions are distributed under GNU Lesser General Public License, version 2.1 .

last update: Mis à jour il y a plus de 3 ans